Error en libavcodec


  • 0

    Me ha salido esto en Twitter y no tengo ni p*** idea de cómo arreglarlo. El tema es que no me deja reproducir los vídeos solo en esa página.
    El sistema operativo es Ubuntu.

    0_1479716972656_instantánea6.png



  • 1

    Te pide actualizar esa librería.
    Mira a ver si un sudo apt-get upgrade lo hace :elboinas:



  • 2

    Nu :(



  • 3

    Si tienes firefox prueba esto:

    about:config en la barra de direcciones

    Luego teclea libavcodec para filtrar lo que quieres toquetear (cuando tengas libavc ya debe de salir)

    Entonces te sale una de las entradas:
    media.libavcodec.allow-obsolete y lo pones a True (clickas dos veces)



  • 4

    @dehm arreglado. ¡¡Gracias!!



  • 5

    Google es tu amigo: http://superuser.com/questions/1137029/libavcodec-may-be-vulnerable-message-in-firefox

    PD: Usar la versión afectada no es recomendable, deberías intentar actualizar.



  • 6

    @kNN busqué en google, pero si no me salen resultados en gallego, no me entero :nusenuse:

    No me actualiza solo, y tampoco tengo muy claro cómo actualizarlo a mano.



  • 7

    @mk_ultra dijo en Error en libavcodec:

    @kNN busqué en google, pero si no me salen resultados en gallego, no me entero :nusenuse:

    No me actualiza solo, y tampoco tengo muy claro cómo actualizarlo a mano.

    qué versión tienes de ubuntu? yo tenía un portátil que tenía la 15.04 y al marcar en configuración sólo actualizar a las versiones LTS se quedó sin actualizarse y sin soporte.

    edit: puedes ver la versión poniendo lsb_release -a



  • 8

    mira a ver las dependencias con ldd



  • 9

    @Pixel dijo en Error en libavcodec:

    @mk_ultra dijo en Error en libavcodec:

    @kNN busqué en google, pero si no me salen resultados en gallego, no me entero :nusenuse:

    No me actualiza solo, y tampoco tengo muy claro cómo actualizarlo a mano.

    qué versión tienes de ubuntu? yo tenía un portátil que tenía la 15.04 y al marcar en configuración sólo actualizar a las versiones LTS se quedó sin actualizarse y sin soporte.

    edit: puedes ver la versión poniendo lsb_release -a

    Va a ser eso. La única y última vez que intenté actualizar la versión tuve que formatear porque me petó el portatil.

    La verdad es que paso de complicarme solo por no poder ver los vídeos de Twitter (que ya puedo).

    PD:

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.04.2 LTS
    Release: 14.04
    Codename: trusty



  • 10

    @erpatata dijo en Error en libavcodec:

    mira a ver las dependencias con ldd

    Ni idea de qué es eso, hoyga.



  • 11

    @mk_ultra dijo en Error en libavcodec:

    @Pixel dijo en Error en libavcodec:

    @mk_ultra dijo en Error en libavcodec:

    @kNN busqué en google, pero si no me salen resultados en gallego, no me entero :nusenuse:

    No me actualiza solo, y tampoco tengo muy claro cómo actualizarlo a mano.

    qué versión tienes de ubuntu? yo tenía un portátil que tenía la 15.04 y al marcar en configuración sólo actualizar a las versiones LTS se quedó sin actualizarse y sin soporte.

    edit: puedes ver la versión poniendo lsb_release -a

    Va a ser eso. La única y última vez que intenté actualizar la versión tuve que formatear porque me petó el portatil.

    La verdad es que paso de complicarme solo por no poder ver los vídeos de Twitter (que ya puedo).

    PD:

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.04.2 LTS
    Release: 14.04
    Codename: trusty

    La versión 14 aún tiene soporte hasta 2019, así que te deberían llegar las actualizaciones normales :nusenuse:

    Puedes hacer:
    sudo apt-get update y después sudo apt-get upgrade. Antes de actualizar te dirá los paquetes que va a actualizar y tal, y luego ya pones "S" (si) o "N"(no) según si quieres actualizar o no.

    Actualizar ubuntu es normal y no debería petar el portátil :roto2nuse:

    @erpatata dijo en Error en libavcodec:

    mira a ver las dependencias con ldd

    ldd? :eing: yo también quiero saber lo que es



  • 12

    @mk_ultra dijo en Error en libavcodec:

    @dehm arreglado. ¡¡Gracias!!

    ¿Y qué pasa con mi cyberbeso? :dale2:

    A todo esto, ¿que versión de Firefox tienes? A mi ayer se me actualizó a la 50



  • 13

    @dehm dijo en Error en libavcodec:

    @mk_ultra dijo en Error en libavcodec:

    @dehm arreglado. ¡¡Gracias!!

    ¿Y qué pasa con mi cyberbeso? :dale2:

    A todo esto, ¿que versión de Firefox tienes? A mi ayer se me actualizó a la 50

    La 50 también desde hace unos días.

    Besis de fibra.



  • 14

    @Pixel

    ldd es un comando para ver a qué librerías enlaza tu binario (ejecutable) cuando lo invocas.

    Por ejemplo, vete a /usr/bin (por ir a un sitio donde hay muchos ejecutables) y teclea:
    ldd nombredelejecutable

    Una muestra:
    [email protected] /usr/bin $ ldd zip

    Y esto es lo que saca:

    linux-vdso.so.1 =>  (0x00007ffe4fd12000)
    libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f54c1040000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f54c0c77000)
    /lib64/ld-linux-x86-64.so.2 (0x0000564fe3136000)


  • 15

    @dehm dijo en Error en libavcodec:

    @Pixel

    ldd es un comando para ver a qué librerías enlaza tu binario (ejecutable) cuando lo invocas.

    Por ejemplo, vete a /usr/bin (por ir a un sitio donde hay muchos ejecutables) y teclea:
    ldd nombredelejecutable

    Una muestra:
    [email protected] /usr/bin $ ldd zip

    Y esto es lo que saca:

    linux-vdso.so.1 => (0x00007ffe4fd12000)
    libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f54c1040000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f54c0c77000)
    /lib64/ld-linux-x86-64.so.2 (0x0000564fe3136000)

    ah guay, pero luego si falta algo sigues con las mismas, no? Vamos que te toca instalar haciendo un sudo apt-get install __________ o actualizar con sudo apt-get upgrade -y



  • 16

    @Pixel dijo en Error en libavcodec:

    @dehm dijo en Error en libavcodec:

    @Pixel

    ldd es un comando para ver a qué librerías enlaza tu binario (ejecutable) cuando lo invocas.

    Por ejemplo, vete a /usr/bin (por ir a un sitio donde hay muchos ejecutables) y teclea:
    ldd nombredelejecutable

    Una muestra:
    [email protected] /usr/bin $ ldd zip

    Y esto es lo que saca:

    linux-vdso.so.1 => (0x00007ffe4fd12000)
    libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f54c1040000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f54c0c77000)
    /lib64/ld-linux-x86-64.so.2 (0x0000564fe3136000)

    ah guay, pero luego si falta algo sigues con las mismas, no? Vamos que te toca instalar haciendo un sudo apt-get install __________ o actualizar con sudo apt-get upgrade -y

    La verdad es que ni idea. Siempre he pensado que es sólo a título informativo :confundio:

    A ver si @erpatata nos saca de dudas



  • 17

    yo creo que puedes comprobar si te falta alguna librería de esa forma, quizas tengas algún link a alguna librería no existente y puedas bajartela manualmente en algún repositorio e intalartela a base de make install.




Has perdido la conexión. Reconectando a Éxodo.